Not logged inOpenClonk Forum
Up Topic General / Help and Questions / Setting SystemDataPath
- - By Marzanna [se] Date 2018-02-22 21:41
I compiled openclonk but it set SystemDataPath to "/usr/local/share/games/openclonk/" but I have all data files in the same directory with binaries.
How do I specify SystemDataPath?
Parent - - By Luchs Date 2018-02-22 21:48
If you want to have one self-contained folder with the binaries and the data files, call cmake -DWITH_AUTOMATIC_UPDATE=ON (or switch that option in the CMake GUI), then recompile.

SystemDataPath is intended for installation like Linux distributions do: binaries to /usr/bin (or similar) and data files to /usr/share.
Parent - - By Marzanna [se] Date 2018-02-23 20:59
Thank you. It worked. Now I can look at debug trace.
$ ./openclonk
[22:57:51] OpenClonk
[22:57:51] Version: 8.0 unix linux-x86_64 (85d9c2c41039 - 2018-02-04 16:39:08 +0100)
[22:57:51] ExePath: "/home/marzanna/Games/openclonk-8.0/"
[22:57:51] SystemDataPath: "/home/marzanna/Games/openclonk-8.0/"
[22:57:51] UserDataPath: "/home/marzanna/.clonk/openclonk/"
[22:57:51] Command line: ./openclonk
[22:57:51]   gl: Create first context...
[22:57:51] GL 3.2.0 NVIDIA 387.34 on GeForce GTX 950M/PCIe/SSE2 (NVIDIA Corporation)
[22:57:51] No Gamepad found
[22:57:51] Loading graphics...
[22:57:52] SDL_mixer runtime version is 2.0.1 (compiled with 2.0.1)
8.0 unix: Caught signal SIGSEGV (0x00007ggd76f0c000)
Is it a bug? Should I report it?
Parent - - By Luchs Date 2018-02-23 23:30
Yeah, seems to be a bug. You're building with SDL_mixer, which isn't tested as well as with OpenAL as audio library. Try installing your distribution's OpenAL packages ( libalut-dev libvorbis-dev libopenal-dev on Debian and ubuntu), re-run cmake and rebuild. It should say "Using Audio toolkit: OpenAL" in cmake output.
Parent - By Marzanna [se] Date 2018-02-24 18:29
Thank you! Now I can play OpenClonk!
Up Topic General / Help and Questions / Setting SystemDataPath

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill