Not logged inOpenClonk Forum
Up Topic General / Help and Questions / Internet Play
- - By ClonkOptimist Date 2021-02-07 17:21
Hello everybody,
I try to play the Snapshot via Internet (Version from Jan21), but I can not Connect nor can my friend connect to my. I guess the problem ist, that in my Ubuntu Version the Handshake failed, since I have testet the Port forwarding and cannot see any other games, like my friend did.

Is there any Help?
Kind regrades

gnutls_handshake() failed: Handshake failed
Parent - - By Zapper [de] Date 2021-02-08 10:28
Where does the error appear?
Does it appear already in the online games list or only when you see your friends came, click on it and try to connect?

If it's the earlier, you could connect directly to the IP as a workaround. It might have something to do with this pull request. Luchs?
Parent - - By ClonkOptimist Date 2021-02-08 22:05
It already happens in the online list and also prevent other to join my game.
Later I found also how to report bugs and issued the bug correctly. So my guess is, that it blocks all network communication.
Parent - - By Zapper [de] Date 2021-02-09 09:21

Okay, what you can try is that the host looks up their IP (e.g. on ), sends it to the other one who then copy&pastes it into "IP" field below the network list even if the list shows an error.
Then an entry "Direct join" should appear in the list above and display the game.
Seems like the problem is when the game tries to contact the master server, which would then hopefully be no issue with a direct join

PS: Just for completeness, does a similar error also appear when you go to the "Mods" menu entry in the main menu? That should load a list of available mods from our website here
Parent - By Mupf [de] Date 2021-02-09 09:27
I can confirm this error on both the server list and the mods menu on Ubuntu 20.04.
Parent - By ClonkOptimist Date 2021-02-09 12:13
Hi Zapper,

yes It happend in the "Mods" list as well.

Connecting via IP was the first thing I tried, enable portforwarding but did not work.
Parent - - By ClonkOptimist Date 2021-02-09 22:00 Edited 2021-02-09 22:03
Okay I was currious and tried the following.

I had to instances of OC snap open and looked if I can connect localy, which I can not.
  I will attach a picture of the Error, since the were a 2nd one poping up from time to time.

The timeout message is also teh same if I try to connect to someone else via IP-adress
Parent - - By Zapper [de] Date 2021-02-10 10:35
That's odd.

What you could try as a workaround would be downloading a slightly older snapshot from before the change that I suspect to be the reason.
On the snapshot side, the second entry "lang-fr" is from 6 months ago. It does not have the "Mods" dialogue but I don't think much has changed gameplay wise. So hopefully it will allow you to play the game!

Direct link (Linux version):
Parent - By ClonkOptimist Date 2021-02-10 17:14
Yes that one is going to work. Thx
(Have seen a Game, did not try to join it)
Up Topic General / Help and Questions / Internet Play

Powered by mwForum 2.29.7 © 1999-2015 Markus Wichitill